Caching not working on search page




Wordpress LScache Plugin: Caching not working on search page


Why the caching not working on the search page but on other pages it is working fine ?? https://website.com/?s=keyword Debug log https://i.imgur.com/S53dQ6z.png Here is the response header Image: https://i.imgur.com/tiwvQlj.png strict-transport-security: max-age=15552000 includeSubDomains vary: Accept-Encoding x-content-type-options: nosniff x-frame-options: SAMEORIGIN x-litespeed-cache-control: no-cache x-litespeed-tag: 461_HTTP.200 x-xss-protection: 1 mode=block LiteSpeed decided not to cache search result page, but in my opinion it should, but needs an extra setting to define TTL for search result page in plugin configuration. It would be even better if the URLs of the search results were written into the wp_litespeed_url table, then the crawler could also crawl the search result pages and would be cached with it. @CacheCrawler It would be even better if the URLs of the search results were written into the wp_litespeed_url table . How can I do that in an easy way ? How can I do that in an easy way ?How can I do that in an easy way ? You could do that, but with next udate of LSache plugin it will be overwritten, so wait for any updates. I already posted this suggestion to LiteSpeed Slack. @CacheCrawler ok, thank you for your reply. Hi, you can go to Cache -> Cache -> Force Cache URIs add your search page inital string , e.g. if you search result page is like https://domain.com/?s=something&post_type=product then you can just put s= into it , with a TTL value like s= 3600 this will cache search result page for 3600 seconds.
Do you need help?
We are online almost any time and ready to answer any question. The answer to your question will come faster than it takes you to release the mouse button.

Ask A Question